CMSMS 1.11.9 "Bartolome" veröffentlicht

Zur Korrektur von in der Vorversion enthaltener Fehler wurde heute CMS Made Simple 1.11.9 "Bartolome" veröffentlicht.

Konkret wurde mit der Version 1.11.8 ein neues Ereignis eingefügt (TemplatePreFetch), die Modulen wie zum Beispiel CmsTouch und TemplateExternalizer zu erweiterten Funktionalitäten verhilft. Jedoch wurde das Datenbank-Schema nicht richtig geändert, so dass dieses Ereignis nur Anwendern mit einer frischen Installation zur Verfügung stand.

Außerdem wurde das Berechtigungsmodell angepasst - Benutzer mit den Berechtigungen 'Modify Any Page' und 'Remove Content' können jetzt fast jede Seite löschen. Die Seiten vom Inhaltstyp "Fehlerseite" werden jetzt durch das Suchmodul nicht mehr indiziert. Ein paar Sicherheitslücken wurden geschlossen und kleinere Korrekturen eingefügt. Weitere Details finden Sie in der Datei /doc/CHANGELOG.txt.

Da das Schema der Datenbank geändert wurde, gibt es für diese Version keine Diff-Pakete. Für eine Aktualisierung müssen Sie sich entweder die Vollversion oder aber die englische Basisversion und die benötigten Sprachpakete herunter laden. Nach dem Hochladen aller Dateien auf Ihren Host können Sie über den Aufruf des Pfades /install/upgrade.php den Aktualisierungsprozess starten.

Da mit dieser Version ein paar Sicherheitslücken geschlossen und Abhängigkeiten von PHP 5.3 korrigiert wurden, sollten Sie Ihre Webseite schnellstmöglich aktualisieren.

Zurück

Impressum  ·  Datenschutz  ·  Kontakt  ·  Spenden  ·  Inhaltsverzeichnis

© Copyright 2006-2018 by Andreas Just