Du bist nicht angemeldet. Der Zugriff auf einige Boards wurde daher deaktiviert.

#1 02. November 2018 15:49

rx9
hat von CMS/ms gehört
Registriert: 17. Juni 2017
Beiträge: 4

[GELÖST] Probleme nach Upgade 1.12.2 auf 2.2.8 mit dem Cataloger Modul

Hallo allerseits,

ich habe mich an ein längst überfälliges Update von Version 1.12.2 auf 2.2.8 gewagt. Nachdem ich erst einen Error 500 und Probleme mit diversen Modulen hatte. habe ich es nun immerhin geschafft mich im Backend einzuloggen und die Seite wieder halbwegs zum Laufen zu bringen.
Was allerdings nicht mehr funktioniert ist das Cataloger Modul. Im Frontend wird die Fehlermeldung

[== ERROR ==]
Warning: Declaration of CatalogCategory::AddProperty($name, $priority, $tab = self::TAB_MAIN, $required = false) should be compatible with ContentBase::AddProperty($name, $priority, $tab = self::TAB_MAIN, $required = false, $basic = false) in /cmsms/modules/Cataloger/lib/class.CatalogCategory.php on line 711 Warning: Declaration of CatalogItem::AddProperty($name, $priority, $tab = self::TAB_MAIN, $required = false) should be compatible with ContentBase::AddProperty($name, $priority, $tab = self::TAB_MAIN, $required = false, $basic = false) in /cmsms/modules/Cataloger/lib/class.CatalogItem.php on line 659

ausgegeben. Ich habe das Modul auf die neuste Version aktualisiert und versucht in den Cataloger Templates die Smarty Scopes nach der Anleitung https://docs.cmsmadesimple.org/upgrading/to-cmsms-2.x umzustellen. Aber ich bin leider an einem Punkt angekommen, an dem ich nicht weiter komme. Hat jemand eine Idee?

Liebe Grüße!

Beitrag geändert von rx9 (02. November 2018 22:15)

Offline

#2 02. November 2018 19:52

NaN
Moderator
Ort: Halle (Saale)
Registriert: 09. November 2010
Beiträge: 4.188

Re: [GELÖST] Probleme nach Upgade 1.12.2 auf 2.2.8 mit dem Cataloger Modul

Warning: Declaration of ... should be compatible with ...

Der Fehler lässt sich leicht beheben.
Ist ein Fehler im Cataloger Modul.
Ändere einfach die Argumente der Funktion in der Datei "modules/Cataloger/lib/class.CatalogCategory.php" in Zeile 711:

AddProperty($name, $priority, $tab = self::TAB_MAIN, $required = false) 

in

AddProperty($name, $priority, $tab = self::TAB_MAIN, $required = false, $basic = false)

Dasselbe in der Datei "modules/Cataloger/lib/class.CatalogItem.php" in Zeile 659

Offline

#3 02. November 2018 22:13

rx9
hat von CMS/ms gehört
Registriert: 17. Juni 2017
Beiträge: 4

Re: [GELÖST] Probleme nach Upgade 1.12.2 auf 2.2.8 mit dem Cataloger Modul

Vielen Dank, hat geholfen!!

Offline