Du bist nicht angemeldet. Der Zugriff auf einige Boards wurde daher deaktiviert.

#1 31. Mai 2018 10:04

anne66
probiert CMS/ms aus
Registriert: 21. April 2011
Beiträge: 55
Webseite

Kein Admin-Zugang trotz korrekter Daten

Moin,
ich habe ein sehr seltsames Problem: ich bekomme keinen Zugang zum Admin-Bereich, obwohl ich über den Zugang zur Datenbank in die Db-Tabelle cms_users den Nutzer sehen konnte und die Zugangsdaten auslesen konnte. Ich habe einen Screenshot mal angehängt.
Die Versionsnummer ist 1.11.7
Ich nutze firefox am mac
die Seite ist noch nicht ssl-geschützt.
Ich würde mich freuen, wenn jemand einen Tipp hat, wo das Problem liegt.
Vielen Dank und einen sonnigen Tag
Anne

Offline

#2 31. Mai 2018 13:54

redigo/
Server-Pate
Ort: Zürich
Registriert: 20. Januar 2011
Beiträge: 485
Webseite

Re: Kein Admin-Zugang trotz korrekter Daten

Falls das Problem jetzt immer noch besteht: In solchen Fällen hilft manchmal ein Browser-Neustart oder -wechsel.

Offline

#3 01. Juni 2018 08:59

anne66
probiert CMS/ms aus
Registriert: 21. April 2011
Beiträge: 55
Webseite

Re: Kein Admin-Zugang trotz korrekter Daten

Ja, das Problem besteht und ich habe es auch auf anderen browsern und Rechnern versucht. Ich erhalte zwar von den Kunden Zugangsdaten, aber die funktionieren alle nicht. Ich verzweifle langsam  cry

Offline

#4 01. Juni 2018 10:06

anne66
probiert CMS/ms aus
Registriert: 21. April 2011
Beiträge: 55
Webseite

Re: Kein Admin-Zugang trotz korrekter Daten

selbst wenn ich in phpmyadmin die zugangsdaten ändere, tut sich nix. Ich bin da aber unsicher, ob ich da das Richtige tue. Ich weiß nicht, ob ich nach der Spaltenänderung noch ganz rechts auf "php-code erzeugen" klicken muss. Ich kenne mich damit nicht aus...

Offline

#5 01. Juni 2018 10:56

NaN
Moderator
Ort: Halle (Saale)
Registriert: 09. November 2010
Beiträge: 4.171

Re: Kein Admin-Zugang trotz korrekter Daten

Wenn Du da in phpMyAdmin das Passwort änderst, damit kommst Du nicht weit. Die Passwörter sind verschlüsselt und "gesalzen". D.h. das verschlüsselte Passwort setzt sich aus mehreren Teilen zusammen, wovon Du nur einen kennst. (der zweite steht zwar auch in der DB, aber mit einem SQL-Befehl geht das leichter: Hier haben wir verschiedene Möglichkeiten um die Zugangsdaten wieder zurückzusetzen.

Bei dem SQL-Script von Nockenfell kann man das Passwort für jeden x-beliebigen User neu setzen. Dazu muss man aber den Usernamen kennen (und im SQL-Script eintragen; ganz hinten 'USER_NAME' mit Deinem Usernamen ersetzen und 'NEW_PASSWORD' mit dem neuen Passwort). Einfach copy&paste in phpMyAdmin ausführen.

Das PHP-Script im selben Thema setzt das Passwort des Benutzers mit der ID 1 neu. Egal wie der heißt. ID 1 bedeutet soviel wie "Superadmin" (also der, der das CMS installiert hat). Das ist hilfreich, wenn man die Zugangsdaten komplett vergessen hat. (allerdings braucht man wenigstens FTP-Zugang und dann kommt man ja auch an die Zugangsdaten der Datenbank ran und kann zumindest wieder den Usernamen in Erfahrung bringen)

Offline

#6 05. Juni 2018 14:28

anne66
probiert CMS/ms aus
Registriert: 21. April 2011
Beiträge: 55
Webseite

Re: Kein Admin-Zugang trotz korrekter Daten

Danke Nan für die ausführlichen Infos. Hatte die letzten Tage keine Zeit, mich überhaupt um diese Seite zu kümmern. Ich schaue' mir alles in Ruhe an und schau' mal, ob ich so weiterkomme - oder vielleicht doch noch vom Eigentümer die richtigen Daten bekomme ...
Herzliche Grüße
Anne

Offline

#7 21. Juni 2018 10:25

anne66
probiert CMS/ms aus
Registriert: 21. April 2011
Beiträge: 55
Webseite

Re: Kein Admin-Zugang trotz korrekter Daten

Gelöst: der Kunde hat es geschafft, mir vier mal falsche Passwörter zu nennen (OMG) Danke für eure Zeit! Herzliche Grüße Anne

Offline