Du bist nicht angemeldet. Der Zugriff auf einige Boards wurde daher deaktiviert.

#1 17. November 2017 23:04

Spaceman
hat von CMS/ms gehört
Registriert: 17. November 2017
Beiträge: 4

Fehler bei der Erzeugung der Datenbanken

Guten Abend zusammen,

ich bin gerade dabei, auf meinem QNAP-NAS die Version 1.12.2 von CMS/made simple zu installieren. Bisher habe ich mich an die Beschreibung im Bereich "Dokumentation" gehalten und alles hat funktioniert. Nun kommt es aber beim Anlegen der Tabellen für die Datenbank zu einem Fehler:

Creating additional_users table...[done]
Adding admin_bookmarks table...[done]
Creating adminlog table...[done]
Adding admin_recent_pages table...[done]
Creating content table...[done]
Creating content_props table...[done]
Adding crossref table...[done]
Creating css table...[done]
Creating css_assoc table...[done]
Creating event_handlers table...[done]
Creating events table...[done]
Creating group_perms table...[done]
Creating groups table...[done]
Creating htmlblobs table...[done]
Creating additional_htmlblob_users table...[done]
Creating modules table...[done]
Creating module_deps table...[done]
Adding module_templates table...[done]
Creating permissions table...[done]
Creating siteprefs table...[done]
Creating templates table...[done]
Creating user_groups table...[done]
Creating userprefs table...[done]
Creating users table...[done]
Creating userplugins table...[done]
Creating version table...[done]
Importing sample data...Invalid query: INSERT INTO cms_additional_htmlblob_users ( ADDITIONAL_HTMLBLOB_USERS_ID, USER_ID, HTMLBLOB_ID ) VALUES ( 6, 1, 5 );

Wenn ich das Log richtig interpretiere, dann müsste die genannte Tabelle cms_additional_htmlblob_users zuvor angelegt worden sein und an der Stelle, an der der Fehler auftritt, findet ein Import statt. Dieser schlägt fehl.

Was die Installation anbetrifft, so habe ich phpmyadmin mit der Version 4.7.4 im Einsatz und dort ist sowohl eine Datenbank cms angelegt als auch - wie während des Installationsprozesses vorgeschlagen - ein User cms_user mit den entsprechenden Privilegien.

Was merkwürdig ist: keine der im Log genannten Datenbanken ist angelegt.

Woran könnte das liegen?!

Vielen Dank für die Unterstützung!!

Beitrag geändert von Spaceman (19. November 2017 22:09)

Offline

#2 22. November 2017 16:50

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.762
Webseite

Re: Fehler bei der Erzeugung der Datenbanken

Hatten vor längerem schon mal ein Thema zum QNAP

https://www.cmsmadesimple.de/forum/view … hp?id=3711

Hast du mal diese Version probiert?

https://www.qnap.com/de-de/app_center/?type_choose=CMS

Alternativ auf einem lokalen Webserver installieren und dann den DB-Dump einspielen ...


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline

#3 25. November 2017 10:25

Spaceman
hat von CMS/ms gehört
Registriert: 17. November 2017
Beiträge: 4

Re: Fehler bei der Erzeugung der Datenbanken

Mojn cyberman,

danke für Deine Rückmeldung.

Die von QNAP angebotene Version 1.11.6 hatte ich erfolgreich zuerst aus dem App-Center von QNAP installiert. Im Rahmen der Installation wurde allerdings unter der Datenbank cms ebenfalls keine Tabelle angelegt, obwohl die Rechte vorliegen. Vielleicht passiert das ohnehin nicht, jedoch ist es vom Kern her genau das, was später nach meiner Meinung zum Abbruch der Installation bei Version 1.12.2 führt.

Da die von QNAP gelieferte Version nicht ganz aktuell ist, wollte ich gerne eine neuere Version installieren. Eben die Version 1.12.2, die aktuell auf der deutschen Seite angeboten wird. Folglich habe ich die genannte Version 1.11.6 wieder gelöscht und die Installation von 1.12.2 gestartet. Hier taucht nun der bereits genannte Fehler auf.

Zu Testzwecken habe ich einmal Joomla, Wordpress oder Concrete als cms installiert. Bei allen werden in die vorliegenden Datenbanken im Rahmen der Installation auch Tabellen geschrieben. Nur bei CMS/MS eben nicht. Allerdings kann ich mir nicht erklären, warum. Die Rechte sind analog gesetzt.

Daher danke für den QNAP-Beitrag aus dem Forum, er trifft aber im Kern nach meiner Meinung nicht die Fragestellung.

Da ich das Prinzip von CMS/MS sehr überzeugend finde, würde ich gerne bei diesem CMS bleiben. Vielleicht lässt sich die Fragestellung auch dadurch klären, dass ich "nur ein Update" mache?!

Was schlägst Du vor?!

Vielen Dank für Deine Rückmeldung.

Offline

#4 25. November 2017 12:26

Spaceman
hat von CMS/ms gehört
Registriert: 17. November 2017
Beiträge: 4

Re: Fehler bei der Erzeugung der Datenbanken

Hallo Cyberman,

mit dem Update hat es geklappt, die Version 1.12.2 ist nun installiert (hierzu gleich noch eine Frage). Für das Upgrade habe ich zunächst die Version 1.12.1 aus dem FORGE geladen. Dann habe ich das Upgrade durchgeführt und es wurde mir in der Übersicht zu Beginn angezeigt, dass sich eine Änderung an der PHP.INI herbeiführen muss, und zwar von

error_reporting  =  E_ALL & ~E_NOTICE auf

error_reporting = E_ALL & ~E_STRICT & ~E_DEPRECATED

Das ist hier bereits behandelt.

http://www.cmsmadesimple.de/forum/viewtopic.php?id=983

Gesagt, getan ... und fertig. Danach der gleiche Vorgang mit 1.12.2. Die Version 1.12.2 läuft nun. Das ist ja die maximal verfügbare Version auf der deutschen Seite. Danke also noch einmal für Deinen Input, er hat mich gewissermaßen erst auf den richtigen Weg gebracht.

Auf der englischen Seite gibt es nun noch aktuellere Versionen, die aktuellste ist die Version 2.2.3.1. Hier habe ich aber schon gemerkt, dass einigermaßen kontrovers über die Versionen ab 2.x diskutiert wird, weil hier inhaltlich wohl ein paar grundlegende Änderungen waren. Wie siehst Du das mit einem Upgrade?!

Danke für eine kurze Rückmeldung!

Beitrag geändert von Spaceman (01. December 2017 11:46)

Offline

#5 02. December 2017 22:56

Janl
Server-Pate
Ort: Freistadt, Österreich
Registriert: 13. December 2010
Beiträge: 1.043
Webseite

Re: Fehler bei der Erzeugung der Datenbanken

Wenn man mit CMSMS 2.2.4 arbeiten will muss gerechnet werden mit viel Suchen am Anfang. In der Bedienung sind viel Sachen anders organisiert, in mein Gefühl weniger logisch als bei der Serie 1.
Für mich ist es erst ab Version 2.3.1 wieder brauchbar. Nur muss ich mehr rundum klicken um alles zu erledigen. Updates von 1.12.2 nach 2er schiebe ich noch immer vor mich aus, in gewisse Hoffnung . . . . frag Cyberman mal.

MfG
Jan


Ubuntu 16.04 mit KDE - LAMP

Offline

#6 05. December 2017 13:54

Spaceman
hat von CMS/ms gehört
Registriert: 17. November 2017
Beiträge: 4

Re: Fehler bei der Erzeugung der Datenbanken

Servus Janl,

vielen Dank für Deine Rückmeldung. Dann werde ich wohl auch ein wenig ... "schieben".

big_smile
Spaceman

Offline

#7 05. December 2017 21:20

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.762
Webseite

Re: Fehler bei der Erzeugung der Datenbanken

Janl schrieb:

Updates von 1.12.2 nach 2er schiebe ich noch immer vor mich aus, in gewisse Hoffnung . . . . frag Cyberman mal.

Frag nicht, wie oft ich meine diesbezügliche Roadmap schon verschoben habe - da mir die Zeit etwas davon läuft, soll in der "nächsten" Version der 1er Core zunächst PHP 7.2 tauglich gemacht werden.

PS: Ein Fallback von der 2er wird es nicht geben... bei Interesse also ein Backup ziehen und im Tresor einschließen.


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline